Sign in to follow this  
Followers 0
sysedit

Stacking on xmonad - black screen

4 posts in this topic

Hello everyone,

sorry for the exotic question. When I start Stacking

in a regular window manager like Sawfish it starts

up just fine. But in xmonad I get a black screen

with no sound and no error messages in the terminal.

In my search of the internet and the forum I was unable

to find an answer to this. Also the xmonad irc channel

had no answer on how to fix this.

Any help greatly appreciated.

Sincerely

Sysedit

Share this post


Link to post
Share on other sites

Sorry for bumping this (relatively) old post, but I was experiencing the same issue and setting the window manager name to "LG3D" solved it for me. By the way, this is the same think you can do to fix some java apps which start up with a blank, grey, window (when using a tiling wm such as xmonad).

Edit: I just checked that enabling either XMonad.Hooks.EwmhDesktops or XMonad.Hooks.ICCCMFocus seem to work, too.

Share this post


Link to post
Share on other sites

I haven't played Stacking yet, but that LG3D hack fixed Costume Quest in xmonad (and I assume it would fix The Cave too, since it suffered from the same problem). Thanks a lot!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0