All Activity

This stream auto-updates     

  1. Yesterday
  2. Changing code in mods

    Progress! It looks like the issue with that example was the mismatch between code and debug.lineinfo. This version does work: local fileName = "Data/Content/Game/DorkForest/Rooms/BobTrap.lua" local disasm = scripts.disassemble(scripts.load(fileName)) local playMumbles = disasm.proto.protos[4] local code = playMumbles.code if #code ~= 305 then error("Wrong proto?") end for i = 95,305 do code[i-5] = code[i] end for i = 301,305 do code[i] = nil end local lineinfo = playMumbles.debug.lineinfo for i = 95,305 do lineinfo[i-5] = lineinfo[i] end for i = 301,305 do lineinfo[i] = nil end assets.overwrite(fileName, scripts.reassemble(disasm)) I figure a truly additive mod should also adjust debug.locvars in case some other mod examining the same function depends on that. (Not that there seem to be many mods doing this sort of thing, or that anybody is still trying to write new mods.)
  3. Last week
  4. Changing code in mods

    In a game mod, is it possible to change the actual code in a game asset? I mean the disassembled instructions, as opposed to just replacing globals and such things (as in this example). All my attempts have just resulted in a failure to load the overwritten asset file, "Failed to load {file} (room may be corrupted)". A simple example: local fileName = "Data/Content/Game/DorkForest/Rooms/BobTrap.lua" local disasm = scripts.disassemble(scripts.load(fileName)) local code = disasm.proto.protos[4].code if #code ~= 305 then error("Wrong proto?") end for i = 95,305 do code[i-5] = code[i] end for i = 301,305 do code[i] = nil end assets.overwrite(fileName, scripts.reassemble(disasm)) protos[4] is the closure assigned to BobTrap.playMumbles. The deleted instructions 90 to 94 are -- SELF 10 1 291 -- MOVE 12 8 -- LOADK 13 43 -- LOADK 14 44 -- CALL 10 5 1 scene:speakLineLeft(alicePortrait, "Hey! You're a sprite, right?", "Default3") I checked that no JMP instructions jump past this code in either direction. So I expected this would just result in skipping one line of dialogue when Bob is freed. But entering the second room just gives the "(room may be corrupted)" error. Also, if I do get replaced code working, is there a good way to insert my own assembly instructions? They appear to be some class-like object, at least to support inst:GET_OPCODE_NAME() etc., but there's no obvious interface to create new objects of that type. Can I just copy one with the correct opcode type from another disassembled function and do inst:SETARG_A() etc.?
  5. The two new dlc packs have now been picked; still hoping for crash, but New ones are Awesome. Who do you want to see next?
  6. Psycho-bug

    thx i'll send a mail. that's the steam version of the game, but it used to work (looong time ago).
  7. Earlier
  8. Psychonauts Missing from the Greek XBOX Marketplace

    Please let us buy Psychonauts 1 in Europe. Unfortunately it still isn't available to buy digitally in the Microsoft Store on Xbox One for us over here.
  9. Xbox One Release?

    Haven't been on this forum in years, came here to see the latest news on this particular question. I'll come back in a few years and try again...
  10. Xbox One Release?

    Could be a chance to see it later to the fusion with Microsoft Game Studios?
  11. Psycho-bug

    The first thing you should do is shoot an email to Out of curiosity, what version of the game do you have? Steam? Humble? GOG? Something else?
  12. Prizes! ...galore? ViewMaster? Yoo-hoo...

    Never mind. Just got the heads up from Fangamer. New toys are on the way.
  13. Psycho-bug

    Hi, i never uninstalled psychonaut since ever, and i can't launch it anymore because (see picture) Raz got a too opened-mind and do not respond to controller. He stays like a stick, i can move him but without any animation. and of course i can't jump in the door to enter the game. I've uninstalled the game and redownload it but it does the same. i tried to upgrade my video driver, just in case, but nothing changed. any idea ?
  14. Where is my Viewmaster? The Raz figure and t-shirt are splendid.
  15. Done and done! Love the mixed adventure/platform concept there.
  16. Thanks! Well, in that case, allow me to plug some creative work of my own: The latest Dan And Ben game: Lair Of The Clockwork God. Pleeeease wishlist it on Steam if you have a sec, it really helps! Announcement trailer:
  17. Yeah, I grew fond of the concept and decided to keep working on it as a pet project. I've always wanted to have a go at making a point-&-click adventure game! I really enjoyed "Ben there, Dan that!" by the way ^^
  18. Late last week I made a little arcade game called Honeycomb CRUNCH to use as a case study in a talk I was giving about making games. I popped it up on Itch and put the source up on GitLab as well. Today I shipped what I suspect will be the final update, which adds some pacing devices (mostly centred around adding discrete stages), some new graphics and a few other tweaks, so it's a little more polished than what's in the video here (which is how these things always seem to go!). I've had an absolute blast making this game, and I frequently found myself getting stuck playing the game for fun when I only intended to test changes >_<
  19. recently bought a VR headset so i been playing alot of VR stuff lately. its kewl. Anyone else think its crazy that this thread Ross made in 2008 is still going? thats like 11 years
  20. If there will to be a sequel for Brutal Legend. Which metal/rock bands and stars do you want to make an appearance?
  21. Great to see this is still continuing in production from its humble Wizard Jam beginnings!
  22. Hello! I'm Fanomatic and I'm currently working on a free, darkly humoristic old-school point n' click adventure game called "Animal Cruelty" where you play as three recently deceased animals who needs to cooperate in order to escape the castle of the evil Dr. Petson! So far I've released a Windows demo of the first room. It features two playable characters, sounds, music, an NPC and many interactions. If you want to try the demo you can do so here The full game will include two more playable rooms (plus an intro and an outro) as well as one more playable character. I try to keep it somewhat small and manageble. You can follow my progress on Twitter: And on Facebook: I hope you enjoy it!
  23. Nous avons plein d'histoires de chat sur notre site, n'hésitez pas à découvrir ! Merci
  24. I got it once, but had to start the game over again. I played through a whole game and didn't get the option to research this,so How do I get it?
  25. Is there anywhere the Director's Cut can still be purchased? is down and it sounds like it is for good. Source:
  26. Can't select/cancel items iOS

    Sorry to hear that you're having issues. Have you tried emailing
  27. Can't select/cancel items iOS

    Tried reinstalling for no more success. Then by taping a lot on the words or by holding my finger, it seems to finish to work after some times. Still, bad playability and non-intuitive...
  28. I have an iPhone 6s, just bought Grim Fandango for 7$ and I can't even select or cancel items. Whatever I do it just "Examine" the items, I then have to close the game to be able to move Manny. It sucks... Waste of money, gonna ask for a refund iOS 12.2
  1. Load more activity