• Announcements

    • Spaff

      These Forums are closing!   10/04/2019

      After more than a decade of serving this community well, these forums have finally run their course and it's time to close them down. That doesn't mean we want to close the doors on our community, quite the opposite!
      Our discord server grows ever busier by the day, and we encourage all Double Fine fans to meet us over there www.discord.gg/doublefine In a short time these forums will become a read only archive and will remain that way until they become needed again.
      You never know, it might happen.  There is... a prophecy. Thank you all for being part of these forums, and remember that the fun is definitely not over - so please join us on Discord! Love ya, Spaff, Tim, Info Cow, and all of Double Fine.
Sign in to follow this  
Vectorferret

[RC8] [Linux] Mouse controls broken regardless of sensitivity

Recommended Posts

I have no idea how to explain this, but the mouse speed is all over the place. No matter what I set the sensitivity too, the mouse is slow, and randomly fast, and gets stuck (no longer moving) from time to time. Is there anyway to make it behave exactly like the old mouse (which seemed to match my normal desktop)?

Share this post


Link to post
Share on other sites

Can you:

1. close the game

2. copy out the Game file in Games\Steam\steamapps\common\Broken Age\saves

3. restart without the Game file in the folder

And let us know if that helps?

Additionally, does it alternate between slow (or frozen) and fast without you changing the setting at all?

Share this post


Link to post
Share on other sites

Experiencing strange mouse behaviour too with the latest patch on linux. Mouse speed seems to slow down depending on the complexity of the scene. For example, with Vella, the mouse speed is slow when she sleeps under the tree but fine when she's in the house.

edited: More accurate description.

Share this post


Link to post
Share on other sites
Can you:

1. close the game

2. copy out the Game file in Games\Steam\steamapps\common\Broken Age\saves

3. restart without the Game file in the folder

And let us know if that helps?

Additionally, does it alternate between slow (or frozen) and fast without you changing the setting at all?

Didn't seem to work. The mouse sensitivity reset to in the middle, which is so slow it was almost impossible even to turn it back up. Eventually I got it up. At full it seems to move close to before most of the time, but gets randomly stuck or will slow down to an insane amount, then suddenly accelerate back up. It seems to be the acceleration curve that's off, rather than the actual speed. Sometimes it goes up way to fast, making clicking with any accuracy impossible, other times it goes so slow that I can't move it.

Edit - It is definitely the acceleration that's off. With high sensitivity it is too imprecise to use at all, but in all sensitivities the acceleration is very slow most of the time. Max just seemed to work right since when I move it around randomly, the overall speed was okay. Actually playing the game didn't work. Every once in awhile it seems to jerk suddenly fast, as if overcompensating for all the slowdowns before.

Share this post


Link to post
Share on other sites

Sorry about this guys. We are unable to reproduce this behavior locally for some reason. I have temporarily disabled mouse sensitivity support on Linux, so if you get the latest patch you should be able to play.

Now we just need to find out what is going, so we can fix this properly.

Share this post


Link to post
Share on other sites

Thanks Oliver. I think my GPU was getting a bit hot, which would explain the slow cursor during complex scenes. I can't confirm Vectorferret's experience, sorry about that.

On another note, the games doesn't start from steam anymore. I can however run it from the terminal with "LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:./lib ./BrokenAge".

Share this post


Link to post
Share on other sites
Thanks Oliver. I think my GPU was getting a bit hot, which would explain the slow cursor during complex scenes. I can't confirm Vectorferret's experience, sorry about that.

On another note, the games doesn't start from steam anymore. I can however run it from the terminal with "LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:./lib ./BrokenAge".

What distro are you using?

The main difference in running the game through Steam is that LD_LIBRARY_PATH contains the path to their standard libraries. I think unless you are using Ubuntu Steam does not guarantee that this will work.

Share this post


Link to post
Share on other sites

Yes, I'm using Ubuntu (ubuntu gnome, actually). Launching from Steam worked fine until the last update 35 minutes ago.

Edit: Here's what steam complains about:

Game update: AppID 232790 "Broken Age", ProcID 3204, IP 0.0.0.0:0

/bin/sh: 1: /home/clapbedon/.local/share/Steam/SteamApps/common/Broken Age/run.sh: not found

CGameStreamThread: Added instance ID 3204 for appid 232790

CGameStreamThread: Set render instance ID 3204 for appid 232790

Share this post


Link to post
Share on other sites
On another note, the games doesn't start from steam anymore. I can however run it from the terminal with "LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:./lib ./BrokenAge".
Same problem here. If I verify the local cache, it fails to validate (on all files) and redownloads. But then still fails to validate. Did a complete delete of local files and then reinstall of them, still no go.

Share this post


Link to post
Share on other sites
On another note, the games doesn't start from steam anymore. I can however run it from the terminal with "LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:./lib ./BrokenAge".
Same problem here. If I verify the local cache, it fails to validate (on all files) and redownloads. But then still fails to validate. Did a complete delete of local files and then reinstall of them, still no go.

Darn. Alright thanks for pointing this out. For some reason Perforce likes to introduce symbols it shouldn't. The run script should be fixed now.

Share this post


Link to post
Share on other sites

Still no longer running (since the mouse patch). I get this error when running manually.

$ ./run.sh

mkdir: cannot create directory ‘lib’: File exists

ln: failed to create symbolic link ‘./lib/libSDL2.so’: File exists

ln: failed to create symbolic link ‘./lib/libSDL2-2.0.so.0’: File exists

./BrokenAge: error while loading shared libraries: libSDL2-2.0.so.0: cannot open shared object file: No such file or directory

Edit - libSDL2-2.0.so.0 is in the lib directory (inside Broken Age), it seems to be a symlink.

lrwxrwxrwx 1 vectorferret vectorferret 26 Jan 25 15:46 libSDL2-2.0.so.0 -> ./lib/libSDL2-2.0.so.0.0.0

Share this post


Link to post
Share on other sites

Problem seems to be resolved in latest build. Mouse movement is good again and game runs.

Share this post


Link to post
Share on other sites
Problem seems to be resolved in latest build. Mouse movement is good again and game runs.

Actually the current version still has the mouse sensitivity disabled. The next patch (which is most likely) the release candidate will have a proper fix. :-)

Share this post


Link to post
Share on other sites
Sign in to follow this