Skolia

Android: Why isn't Broken Age Compatible with Samsung Galaxy Tab S?

Recommended Posts

I have a Samsung Galaxy Tab S from T-Mobile and the Google Play store says that Broken Age for Android won't run on it (It'll run on my Galaxy 5S).

Is there any way to fix this?

Android 4.4.2

Share this post


Link to post
Share on other sites
I have a Samsung Galaxy Tab S from T-Mobile and the Google Play store says that Broken Age for Android won't run on it (It'll run on my Galaxy 5S).

Is there any way to fix this?

Android 4.4.2

The game currently doest support any devices using a 'Mali' GPU, including the Galaxy Tab S unfortunately (I have a 10.5" version, not compatible). I'm unsure if DF ever plan to add support in an update.

http://www.doublefine.com/forums/viewreply/381742/

Share this post


Link to post
Share on other sites
On 5.5.2015 at 4:38 PM, CountDuckula said:

The game currently doest support any devices using a 'Mali' GPU, including the Galaxy Tab S unfortunately (I have a 10.5" version, not compatible). I'm unsure if DF ever plan to add support in an update.

http://www.doublefine.com/forums/viewreply/381742/

Mhm, that link doesn't work anymore. :/

This Christmas my niece got a tablet as a present.
I wanted to make her a gift with broken age, but sadly it said it doesn't work with her tablet. It's an asus zenpad 8 with a Mali T720.

I am really quite sad, i don't want to say it broke my heart, but maybe it was kinda heart breaking ^^  (a little bit) as i guess she won't get another device or laptop or anything anytime soon.

And especially thanks to the german vocals it would have been perfect for her. So i am a slacker backer and loved the whole backing experience and the game as much. And i always kinda had my niece in mind as well. 

I read in the playstore reviews (in germany) that there quite some people sad not to be able to play it with their Galaxy devices as well.

I would be super happy if some when there would be happening something. This game is a kinda all-time-classic already for me.

So i used the search function in the forums here and haven't found another thread with this topic already? Is there one?

Anyone else faced that problems?

I kinda never had a reason to buy it for android for myself, as i got it for pc. But i am surprised on the one hand and really sad, that it isn't for all devices. So if all Malis are not supported, doesn't that make quite a bunch of devices it won't be compatible with?

;(

Share this post


Link to post
Share on other sites

The problem are the drivers for the Mali GPU. They are buggy and do not support all features needed for the game. There is not much DF can do. New drivers have to come from the device and/or GPU manufacturer and these have be included in an Android update...

Share this post


Link to post
Share on other sites
Black Screen
My game starts up, i can hear the music, but I'm only presented with a black screen. my device name is samsung galaxy a5 2017.android 7.0.

Share this post


Link to post
Share on other sites

Sihan: Samsung A5 2017 uses Mali, which according to the above posters is not supported.

 

Share this post


Link to post
Share on other sites

Is this an issue of whitelisting of certain chips or blacklisting?
Or is based on actual feature detection?

Is Mali G71 supported?
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now