Jump to content
Double Fine Action Forums
Sign in to follow this  
buckysrevenge

... and on Linux, too!

Recommended Posts

slackware64 14.0, 3.8.0-final, nvidia gtx 465 with 310.32, alsa

no sound at all, and softlocks upon exit attempt

glxinfo: http://pastebin.com/DfPzuXVA

I haven't installed Steam yet so I haven't tried out the Cave (I will do that shortly), but how did you install Steam? Alien Bob made a nice package for it and I know he hacked it up a bit since Slackware doesn't use pulseaudio, for example...see here (and here). You may have to add a workaround.

Share this post


Link to post
Share on other sites

As seen reported here https://github.com/ValveSoftware/steam-for-linux/issues/1911

I have no sound after an initial play of The Cave. By this I mean I start up the game, sound can be fine. However saving and exiting the game and then relaunching, sound is completely gone in the game.

Restarting the Steam client fixes it, but by that I mean it makes the game work fine (sound and all) for the first launch after restarting Steam, but subsequent re-launches of the game will always kill the sound.

The game also hangs on exit as told by slackware64 above, when this sound quirk is happening.

For the sake of it: glxinfo http://pastebin.com/Ez2vBRHv

I should add I can't see any errors in the terminal output from Steam itself, but if there are auto generated logs or something for The Cave just let me know, but I haven't found any.

Share this post


Link to post
Share on other sites

If you use an Ubuntu based Distro you could use the ppa:xorg-edgers/ppa to update your graphics driver. But be aware: It will only give you a real performance boost with Kernel 3.8 and is still experimental - so it may brake your system.

Also better driver, but also only good with 3.8 are in this ppa: ppa:ubuntu-x-swat/x-updates

Ah, yes, I already know this, but thank you for repeating for future game players!

I'm quite certain that my setup is as performant as it can be.

My question was more for DF Justin (or another DF team member)! Specifically, in the display options menu of The Cave only, what should I tweak to have the most playable framerates, while still being as pretty as possible?

Obviously, some specific knowledge of my setup would be needed for an exact answer, but Double Fine engineers will have the best idea of what graphical options gobble the most shader cycles. Hence, someone on the team could say "Hey, it's all about the shadows... turn those off, and everything else doesn't matter". Or "It's the AA settings that really burn your GPU"... or "It's all the same, dude, turn it all off".

As I mentioned before, I could do this by trial and error, but why? They have the knowledge at DF, it's their engine! They just have to hop in here and tell us how it is, preferably a ranked list, in order of GPU expense (e.g., turn stuff off in this order until it plays how you like).

We can do the rest :-)

Share this post


Link to post
Share on other sites

Hi,

now I bought the came, installed it but I got an error when I want to start it:

Error-Code:

gamer@gaming:/media/truecrypt1/Sonstiges/SteamLibrary/SteamApps/common/TheCave$ ./run_game.sh 

libGL error: failed to load driver: swrast

libGL error: Try again with LIBGL_DEBUG=verbose for more details.

dlopen failed trying to load:

/home/gamer/.local/share/Steam/ubuntu12_32/steamclient.sowith error:

libvstdlib_s.so: cannot open shared object file: No such file or directory

[s_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/gamer/.local/share/Steam/ubuntu12_32/steamclient.so

[s_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

./run_game.sh: Zeile 26:  5640 Speicherzugriffsfehler  (Speicherabzug geschrieben) ./Cave.bin.x86



fglrx-Info:

gamer@gaming:~$ fglrxinfo

libGL error: failed to load driver: swrast

libGL error: Try again with LIBGL_DEBUG=verbose for more details.

display: :0.0  screen: 0

OpenGL vendor string: ATI Technologies Inc.

OpenGL renderer string: ATI Radeon HD 5800 Series 

OpenGL version string: 1.4 (2.1 (4.2.12002 Compatibility Profile Context 9.012))

General Info:

gamer@gaming:~$ uname -a

Linux gaming 3.5.0-18-generic #29-Ubuntu SMP Thu Oct 25 07:26:14 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Seems like a missing library, but which one? And also: Where do I get it from and where do I need to copy it to?

EDIT: Seems to be an fglrx-issue. How I hate this unforsaken ATI driver. >.<

EDIT: Got it fixed some hours ago by forcing the AMD driver to be installed again. Just forget to update the post while playing the guitar. :P

Share this post


Link to post
Share on other sites

slackware64 14.0, 3.8.0-final, nvidia gtx 465 with 310.32, alsa

no sound at all, and softlocks upon exit attempt

glxinfo: http://pastebin.com/DfPzuXVA

I haven't installed Steam yet so I haven't tried out the Cave (I will do that shortly), but how did you install Steam? Alien Bob made a nice package for it and I know he hacked it up a bit since Slackware doesn't use pulseaudio, for example...see here (and here). You may have to add a workaround.

Correct, I am using Alien Bob's package/installer, with pulseaudio to alsa

The Steam client is dynamically linked against pulseaudio libraries, but my

modification to the steam startup script will actually force it to use

Slackware's ALSA for audio output. Pulseaudio will not be used.

Slackware doesn't use pulseaudio.

Any idea on a workaround?

Share this post


Link to post
Share on other sites

slackware64 14.0, 3.8.0-final, nvidia gtx 465 with 310.32, alsa

no sound at all, and softlocks upon exit attempt

glxinfo: http://pastebin.com/DfPzuXVA

I haven't installed Steam yet so I haven't tried out the Cave (I will do that shortly), but how did you install Steam? Alien Bob made a nice package for it and I know he hacked it up a bit since Slackware doesn't use pulseaudio, for example...see here (and here). You may have to add a workaround.

Correct, I am using Alien Bob's package/installer, with pulseaudio to alsa

The Steam client is dynamically linked against pulseaudio libraries, but my

modification to the steam startup script will actually force it to use

Slackware's ALSA for audio output. Pulseaudio will not be used.

Slackware doesn't use pulseaudio.

Any idea on a workaround?

i installed pulse 3.0 from source.....sound works

terrible dependency if you ask me, but thanks for the help.

edit:derp, now sound doesnt work upon 2nd run, like other distros

sigh

Share this post


Link to post
Share on other sites
Will the game take part in the Linux Sales? Would be nice just to hear: "yes", "no", "we'll see" instead of nothing ...

Thanks! ;)

Honestly no idea, but I'll ask people more in the know. I have a feeling nobody's answered since that's one of the things that we have to coordinate with Sega.

Any news for me Justin? ;)

Yup! We can't participate in the sale due to our contract with Sega. Pricing any of the SKUs lower than the others isn't allowed right now so we have to pass on this sale.

Share this post


Link to post
Share on other sites
My question was more for DF Justin (or another DF team member)! Specifically, in the display options menu of The Cave only, what should I tweak to have the most playable framerates, while still being as pretty as possible?

Obviously, some specific knowledge of my setup would be needed for an exact answer, but Double Fine engineers will have the best idea of what graphical options gobble the most shader cycles. Hence, someone on the team could say "Hey, it's all about the shadows... turn those off, and everything else doesn't matter". Or "It's the AA settings that really burn your GPU"... or "It's all the same, dude, turn it all off".

As I mentioned before, I could do this by trial and error, but why? They have the knowledge at DF, it's their engine! They just have to hop in here and tell us how it is, preferably a ranked list, in order of GPU expense (e.g., turn stuff off in this order until it plays how you like).

We can do the rest :-)

That's a great question! The answer is that performance is much more complex than what graphical features consume the most shader cycles. That being said, I can give you some back-of-the-envelope guidance.

The Cave is mostly (but not always) GPU bound, and here are the options sorted roughly in order of importance:

- First, adjust your resolution. Rendering fewer pixels is one of the most direct controls over framerate (unless you are CPU bound)

- Shadows are usually the most expensive (will help the CPU quite a lot, and the GPU a bit)

- High quality effects are next (mostly for GPUs, especially if they are bandwidth starved like many laptops)

- SSAO and DOF are next

- Bloom and FXAA are cheap to render and add a lot to the look of the game, but can help a bit in a pinch.

SSAA, the final option in the visual settings, should be enabled with care. It's off by default, and enabling it turns on 4X super sampling, which effectively multiplies your resolution by 4. Many desktop GPUs from the last couple of years can actually handle that, but it definitely hurts performance.

I hope that helps. It's important to realize, though, that it *is* very difficult to answer the question of what graphics options are best to disable. Not only does it vary from machine to machine, but it's also an aesthetic call. You might want to turn off all options, but use high quality antialiasing. And in terms of shader cycles, are you referring to pixel shader cycles? Vertex shader cycles? Texture fetching? And GPU performance is only half of the story-- what if you are CPU bound? Is it the rendering thread? Overhead in the GPU driver?

The performance characteristics of various PC configurations differs dramatically. A Dell laptop with a Ivy Bridge integrated GPU performs very differently from a retina Macbook with a discrete GPU, an old desktop CPU from behaves differently from a new desktop CPU, maybe you've upgraded your GPU but have a CPU from a couple of years ago, maybe you are running an Eyefinity display at 5760x1080 and maybe you're running a laptop at 1366x768, etc.

With consoles/fixed spec devices, we actually do carefully measure performance and make the appropriate tradeoffs for that platform. That's difficult to do on a PC, though not impossible-- we could measure your machine's performance in various areas, and use settings appropriate for that performance profile. However, most PC games (and when I say PC, I mean Win/OSX/Linux/etc) empower the user with options that they can customize themselves. And, writing software to measure performance and setting configuration options automatically is nice, but it takes engineering time-- and would you rather us spend time on that, or on porting the game to different platforms? And, as I mentioned earlier, there's also an aesthetic component of what graphics settings you find most important.

Share this post


Link to post
Share on other sites

i installed pulse 3.0 from source.....sound works

terrible dependency if you ask me, but thanks for the help.

edit:derp, now sound doesnt work upon 2nd run, like other distros

sigh

I just tried out The Cave on 64-bit Slackware 14.0 (with multilib), using Alien Bob's steamclient-1.0.0.28-i386-1alien. It does not work in xmonad (my window manager of choice), though steam itself does...when I launch The Cave from steam or manually, it just sits there with a black screen and the normal mouse cursor (not The Cave's cursor). The window manager is frozen so I have to Ctrl+Alt+F2 to get to a console and `kill -9` the cave binary (regular kill does not work). Everything works fine though in TWM and KDE. I checked the environment variables in both xmonad and twm and there is nothing out of the ordinary, but I think xmonad's tiling is giving The Cave a bit of trouble. (Apparently there were issues with Steam itself and xmonad during the beta but they have since been fixed). The problem is the same whether I launch The Cave from Steam or manually via the run script. Anyway, dropping to TWM to play The Cave isn't the end of the world right now so I'm content. I did *not* have to install Pulse, and audio works fine (I did install 64-bit and compat32 packages of speex, json-c, OpenAL and a compat32 package of oxygen-gtk2, though I'm not sure if that was necessary).

If I change the resolution from within The Cave, it doesn't work well -- the screen gets cut off if I use anything less than the native resolution (it is rather weird that choosing a lower resolution cuts off...it must be zoomed weirdly or something). The cursor is also offset incorrectly in non-native resolutions so I have to hover well above where the menu options should be to hilight them. Fortunately my video card seems to be able to handle the native resolution.

Share this post


Link to post
Share on other sites

Just wanted to say thanks for the great linux version! Works like a charm out of the box on linux mint 14, and runs really well too.

Great job guys!!!

Share this post


Link to post
Share on other sites

Hi Double Fine,

This weekend I installed Ubuntu 12.10 i386 and finally played "The Cave"

It is very fun, great work folks!! I am dissapointed with Metascore.

Game runs well, but not perfect, I miss more smooth.

When vertical sync. is enabled I see a horrible line, if I use Alt+tab it's gone.

Información sobre el procesador:

Fabricante: GenuineIntel

Velocidad: 3068 Mhz

Procesadores lógicos 8

Procesadores físicos 4

HyperThreading: Compatible

FCMOV: Compatible

SSE2: Compatible

SSE3: Compatible

SSSE3: Compatible

SSE4a: No compatible

SSE41: Compatible

SSE42: Compatible

Información sobre la red:

Velocidad de la red:

Versión del sistema operativo:

Ubuntu 12.10 (32 bits)

Nombre de kernel: Linux

Versión de kernel: 3.5.0-25-generic

Editor de X Server: The X.Org Foundation

Versión de X Server: 11300000

X Window Manager: Compiz

Steam Runtime Version:

Tarjeta de vídeo:

Controlador: ATI Technologies Inc. ATI Radeon HD 5800 Series

Versión de controlador: 4.2.12172 Compatibility Profile Context 12.10.17

Densidad de color del escritorio: 24 bits por píxel

Frecuencia de actualización del monitor: 60 Hz

Identificador del fabricante: 0x1002

Identificador del dispositivo: 0x6899

Número de monitores: 1

Número de tarjetas de vídeo lógicas: 1

Resolución de pantalla principal: 1920 x 1080

Resolución de escritorio: 1920 x 1080

Tamaño de pantalla principal: 20,04" x 11,26" (22,95" diag)

50,9cm x 28,6cm (58,3cm diag)

No se ha detectado la memoria VRAM principal

Tarjeta de sonido:

Dispositivo de sonido: 20K2

Memoria:

RAM: 6054 Mb

Varios:

Idioma de la IU: Español

LANG: es_ES.UTF-8

Micrófono: Not set

Espacio total en disco disponible: 144191 MB

Bloque libre más grande en el disco: 116033 MB

Software Instalado:

Informes de fallos recientes:

Captura de pantalla de 2013-02-25 16:03:29.png

578d003299fda_Capturadepantallade2013-02

Share this post


Link to post
Share on other sites

Hi Ximaceo,

Compiz had lots of issues in the past (Ubuntu 12.10 is two years old) and might well be responsible for the smoothness issues.

Share this post


Link to post
Share on other sites
Hi Ximaceo,

Compiz had lots of issues in the past (Ubuntu 12.10 is two years old) and might well be responsible for the smoothness issues.

Ubuntu 12.10 is the latest version of Ubuntu; it just came out in October (12=2012, 10=October).

Share this post


Link to post
Share on other sites

I haven't seen this mentioned anywhere else, but I've found what looks a lot like the Coach Oleander projection bug in the Steam Linux version of Psychonauts:

http://steamcommunity.com/sharedfiles/filedetails/?id=129955592 (kind of spoilerish)

http://steamcommunity.com/sharedfiles/filedetails/?id=129955633

That last one makes the Adventurer area impossible to finish without trial and error or resorting to walkthroughs.

Share this post


Link to post
Share on other sites

A little bit offtopic, but I tried to look information about problem I got but didn't find anything related.

Tried to run on Windows 7 and Linux (Ubuntu 12.10 x86 with latest updates) on the following configuration:

Core2Quad Q6600, 4GB Ram DDR2, Nvidia GTX 650Ti

Windows copy works perfect, unfortunately Linux one does not. Framerate appears low, game lags even with lowering display resolution, disabling effects, enabling/disabling vsync and so on. Is this problem caused by drivers, local settings or anything related to operation system or just game performance on linux is still improving?

Anyway thanks for this game was brought to Linux ;).

Share this post


Link to post
Share on other sites
A little bit offtopic, but I tried to look information about problem I got but didn't find anything related.

Tried to run on Windows 7 and Linux (Ubuntu 12.10 x86 with latest updates) on the following configuration:

Core2Quad Q6600, 4GB Ram DDR2, Nvidia GTX 650Ti

Windows copy works perfect, unfortunately Linux one does not. Framerate appears low, game lags even with lowering display resolution, disabling effects, enabling/disabling vsync and so on. Is this problem caused by drivers, local settings or anything related to operation system or just game performance on linux is still improving?

Anyway thanks for this game was brought to Linux ;).

Are you using NVIDIA's drivers, or the nouveau drivers that are installed by default? NVIDIA's drivers can't be included in the default install, so you have to enable them. See this page for more information: https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Share this post


Link to post
Share on other sites

kwakubm, try to benchmark the performance on Team Fortress 2 for example. Should run well if it's so may be our problem has the common roots.

Share this post


Link to post
Share on other sites
kwakubm, try to benchmark the performance on Team Fortress 2 for example. Should run well if it's so may be our problem has the common roots.

I installed TF2 and played it, it ran great. Consistently 60+ FPS. So maybe it's not the intel graphics drivers after all...

Share this post


Link to post
Share on other sites

Don't know how many people have tried running The Cave on Linux with Nvidia Optimus (Intel HD video card for low end, Nvidia Mobile Graphics for 3D), but this article and one bit of advice proved invaluable to getting The Cave to run for me on my new system:

http://www.webupd8.org/2012/11/primus-better-performance-and-less.html

When using this, however, The Cave kept crashing, but only through Steam (running The Cave directly using primus did not crash). Then I found some posts online that suggested disabling in-game steam community and now everything works great! (and looks awesome BTW).

Haven't tried the 310 drivers, but will later.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...