Jump to content
Double Fine Action Forums
Sign in to follow this  
Justin Honegger

New Steam Windows and Mac Patch - 2.11.2013

Recommended Posts

http://www.notebookcheck.net/Intel-Graphics-Media-Accelerator-4500MHD-GMA-X4500MHD.9883.0.html

This performance chart shows that graphics card can only run a few "modern" games at playable speed aka above 20-30 fps.

I do know the specs of my GPU. Still all of this is no reason for the whole system to go into total lagging mode! If just ANYBODY could once confirm or disprove the capability of this GPU to run "The Cave" I would just shut up. But so far it's only speculation, no one actually tried to play "The Cave" on his/her machine with the GMA 4500MHD GPU!

I have the game in a tiny 640x480 windows with all fancyness turned off and EVERYTHING get's laggy! I really doubt that this is just a performance issue with this GPU...

Share this post


Link to post
Share on other sites

It is because the Buddha engine where cave is build on is made in a way that you can only play the game solidly if you have at least 30 fps. If you do not everything starts too lag because the engine doesn't have time to process your key presses and other stuff.

That graphics card only has good fps on lowest quality games from the year 2004 - 2005 that's almost 10 years sorry but you cannot expect to run any game on that graphics card.

Share this post


Link to post
Share on other sites
It is because the Buddha engine where cave is build on is made in a way that you can only play the game solidly if you have at least 30 fps. If you do not everything starts too lag because the engine doesn't have time to process your key presses and other stuff.

OK, so now we're getting somewhere...

That graphics card only has good fps on lowest quality games from the year 2004 - 2005 that's almost 10 years sorry but you cannot expect to run any game on that graphics card.

I can play Civilization V very nicely... And in higher resolution than 640x480!

Share this post


Link to post
Share on other sites
It is because the Buddha engine where cave is build on is made in a way that you can only play the game solidly if you have at least 30 fps. If you do not everything starts too lag because the engine doesn't have time to process your key presses and other stuff

And this issue is now done.

Share this post


Link to post
Share on other sites

And this issue is now done.

Yeah, it totally makes sense that YOUR Quadro 160 is in the exact same performance-category as my GMA 4500MHD ("Leistungskategorie 4") and you can play the game without any problems and I can't play the game at all.

Both GPUs have more or less the same core clock, same memory, same shader version, same Directx-compatibility...

Anyone with a GMA 4500MHD: PLEASE tell me it doesn't work for you as well and we can end this topic.

Share this post


Link to post
Share on other sites

ROFL any dedicated card will kick the poo out of an Intel hd card (they are bloody awful). Let it go, you know your laptop can't run the game and you're just trolling now. I can't be bothered to continue having this conversation since you refuse to see what's in front of your face. good luck in getting the game to work I'll see you later.

Share this post


Link to post
Share on other sites

As an OSX user, I'm not finding that the patch fixes the choppiness in the frame rate.

My platform is the 15" rMBP with the 2.6GHz i7 CPU and 16 GiB of memory. The GPU is the NVIDIA GeForce GT 650M with 1024 MB of video memory.

At 800x600 the game play is smooth. At the default resolution, 1440x900 I suspect but cannot verify, the frame rate is obviously choppy. There are noticeable several hundred millisecond pauses in rendering which is especially noticeable when side scrolling.

For grins, I downloaded the 3D demonstration program Unigine Valley. It reports that the GPU can sustain 30fps at the default resolution of 1440x900. AAx8 lower the rate to about 20fps, but it is very stable.

Am I seeing a driver problem? Perhaps the better question is what is the recommended setup for the Cave on this hardware for the best experience?

Share this post


Link to post
Share on other sites
ROFL any dedicated card will kick the poo out of an Intel hd card (they are bloody awful).

OK, my bad, didn't realize the Quadro is a dedicated GPU.

Well anyway, I didn't expect an ADVENTURE GAME to be practically unplayable on my computer as I can play 3D-Games on low resolutions without problems. Must be this fabulous buddha engine...

Topic closed - yes.

Still deeply disappointed - yes.

Share this post


Link to post
Share on other sites
ROFL any dedicated card will kick the poo out of an Intel hd card (they are bloody awful).

OK, my bad, didn't realize the Quadro is a dedicated GPU.

Well anyway, I didn't expect an ADVENTURE GAME to be practically unplayable on my computer as I can play 3D-Games on low resolutions without problems. Must be this fabulous buddha engine...

Topic closed - yes.

Still deeply disappointed - yes.

You cant expect a game company to make a game that's runnable on a gpu that's only meant for office work.

Share this post


Link to post
Share on other sites

You cant expect a game company to make a game that's runnable on a gpu that's only meant for office work.

Of course I can.

As I have stated many times now: Civilization V, Starcraft II, System Shock 2 GOG version are totally playable on my computer and in my humble opinion they don't seem to demand so much more GPU-power.

If Double Fine programs "The Cave" in a way so it is totally unplayable on my computer, it's their decision. They have lost at least one player who is a huge fan of the the old Ron Gilbert Zak McKracken/Indiana Jones/Monkey Island games.

To be honest I think it would be absolutely possible to make an ADVENTURE GAMES (!) which would still be playable on a not so old office notebook, actually I think it would have been a clever move to deliberately make "The Cave" work on office notebooks.

Whatever, I'm done.

Share this post


Link to post
Share on other sites

I'll have a appointment within the next time, when I'm done I'll let you know if the game runs on an Intel GMA 4500 MHD or not (Linux). I am pretty sure it won't, but for gods sake, I'll give it a try. And don't blame DF for your bad hardware please. In focus on gaming your gfx card is very, very bad.

PS: "Leistungsklasse 4" sagt überhaupt nichts aus. Haste bei Notebookcheck vorbeigeschaut oder wie? -.-

EDIT: 800x600, all low, Xubuntu 13.04 Alpha, Kernel 3.8 -> less then 10 FPS. Even if they tune the game a lot and you'll get like 10-15 FPS it won't be running.

Get a gaming mashine for gaming and an office mashine for you work. That's the key.

Share this post


Link to post
Share on other sites
I'll have a appointment within the next time, when I'm done I'll let you know if the game runs on an Intel GMA 4500 MHD or not (Linux). I am pretty sure it won't, but for gods sake, I'll give it a try. And don't blame DF for your bad hardware please. In focus on gaming your gfx card is very, very bad.

Thanx. I don't blame DF, I just never expected an ADVENTURE game (or the starting MENU of an adventure game) to be unplayable on my computer. And I am aware that my GPU is bad.

PS: "Leistungsklasse 4" sagt überhaupt nichts aus. Haste bei Notebookcheck vorbeigeschaut oder wie? -.-

Ja, aber eigentlich nur, um diese Quadro 160 zu suchen ;-)

EDIT: 800x600, all low, Xubuntu 13.04 Alpha, Kernel 3.8 -> less then 10 FPS. Even if they tune the game a lot and you'll get like 10-15 FPS it won't be running.

Get a gaming mashine for gaming and an office mashine for you work. That's the key.

Thanks a lot for checking!

Did you expect such a bad performance? - so vom Gefühl, wenn du "The Cave" siehst? Ich find das so krass, dass selbst das MENÜ (!!!) am Anfang fast den ganzen Rechner einfriert. Diese buddha engine scheint ja wirklich was ganz famoses zu sein...

And my plan was to work more and game less so I gave my gaming PC away many months ago ;-) I would have had a Radeon X800 which is also not the newest GPU but it could have done the trick...

Thx again,

Cornelius

Share this post


Link to post
Share on other sites

Due to the fact I expected it's GPU limited it's exactly what I have expected. Games like SCII e.g. are very good to scale (gfx settings) and limited to CPU - not that much trough GPU. That's the whole secret.

Share this post


Link to post
Share on other sites
Help me turn this off blind please!

Hmm. I'm sorry to hear that. Could you share any info on your machine so we could try to track down the problem?

To disable supersampling without going through the in-game settings, you need to either edit your preferences file, or just erase it. Go to wherever %APPDATA%\Doublefine\TheCave (which is probably C:\Users\[your login name]\AppData\Roaming\Doublefine\TheCave). Then, either erase the prefs.dat file in that folder, or open it with a text editor and change the "SSAA=1" entry to "SSAA=0".

Thanks a bundle! Been stuck trying to turn that off for a few days :/

Share this post


Link to post
Share on other sites

I'm still getting extremely poor performance on my PC, even when running The Cave in low res with everything turned off, only about 12 fps or so. I'd assume my machine should be able to run a game like this in the highest resolution with all the bells and whistles, so I'm guessing it's a bug or incompability issue.

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130104-1431)

BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10

Processor: Intel® Core i7-2600K CPU @ 3.40GHz (8 CPUs), ~3.4GHz

Memory: 8192MB RAM

Available OS Memory: 8168MB RAM

Page File: 2646MB used, 13689MB available

DirectX Version: DirectX 11

---------------

Display Devices

---------------

Card name: NVIDIA GeForce GTX 570

Manufacturer: NVIDIA

Chip type: GeForce GTX 570

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV;_1081&SUBSYS;_25511462&REV;_A1

Display Memory: 4049 MB

Dedicated Memory: 1233 MB

Shared Memory: 2815 MB

Current Mode: 1920 x 1080 (32 bit) (60Hz)

Monitor Name: SyncMaster P2770H/P2770FH (Digital)

Monitor Model: SyncMaster

Monitor Id: SAM0612

Native Mode: 1920 x 1080(p) (60.000Hz)

Output Type: DVI

Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Driver File Version: 9.18.0013.1407 (English)

Driver Version: 9.18.13.1407

DDI Version: 11

Driver Model: WDDM 1.1

Driver Attributes: Final Retail

Driver Date/Size: 2/10/2013 04:25:27, 17987192 bytes

WHQL Logo'd: Yes

WHQL Date Stamp:

Device Identifier: {D7B71E3E-53C1-11CF-AD72-5C051CC2C435}

Vendor ID: 0x10DE

Device ID: 0x1081

SubSys ID: 0x25511462

Revision ID: 0x00A1

Driver Strong Name: oem59.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section077:9.18.13.1407:pci\ven_10de&dev;_1081

Rank Of Driver: 00E02001

Share this post


Link to post
Share on other sites

I can not play the game. It freezes on the Loading screen. I think it might be the SSAA thing - but I have no idea how to find the SSAA=1 or SSAA=0 on my computer. Could someone help me?

This is what I know about my computer:

MacBook Air

Processor: 2GHz Intel Core i7

Memory 8 GB 1600 MHz DDR3

Graphics Intel HD Graphics 4000 512MB

Software: OS X 10.8.2

Thank you.

Share this post


Link to post
Share on other sites

a) Under mountain lion you might first need to make the ~/Library folder visible again.

http://www.macworld.com/article/1161156/view_library_folder_in_lion.html

b) Open prefs.sav with a text (or a hex) editor.

Go to ~/Library/Application Support/DoubleFine/The Cave/ and open prefs.sav. I can't remember if you needed prefs.sav in this folder or the one within the subfolder with the long number. Backup the file and give it a try. You could backup and alter both too.

(http://www.suavetech.com/0xed/0xed.html in case you want to use a hex editor.)

c) Alter the settings.

Change SSAA=1 to SSAA=0 and save the file.

(If you use the hex editor look out for SSAA=1 in the text area and change it to SSAA=0 by selecting the 1 in the text area on the right side but altering the appropriate hex value in the left hex area from 31 to 30, save it, exit.)

d) Run the game.

In case it didn't work out you might want to disable the other gfx options as well (FXAA, SSAO, Shadows, ...).

Bring up the issue on the forum again.

Reminds me that the screen settings in screen.dat are still being ignored and not working.

Share this post


Link to post
Share on other sites

Found the Library/ApplicationSupport section, but there wasn't a DoubleFine folder. I opened all the folders in the Application Support folder and there wasn't anything there that was DoubleFine or The Cave related. The Cave is still installed on my computer.

Do you know if there is another area that the folder might be in?

Thank you.

Share this post


Link to post
Share on other sites

You need the Library folder which is inside your user folder not the one which is tied to your machine.

Share this post


Link to post
Share on other sites

Well, then i'm sorry, this was the obvious thing which instantly came to my mind when i read your post.

The Cave certainly is a great game but it's also one the buggiest pieces of software i've touched in a couple of years with bugs&glitches; which remain since the initial version. Maybe you want to contact someone @DF, maybe they are still fixing bugs, maybe they aren't and are working on other jobs already, i don't know. It's somehow sad as Psychonauts on the Mac also was loaded with issues. It seems like they expanded the platforms too fast without being able to do proper QA and providing reasonable support for all of them.

Share this post


Link to post
Share on other sites

Thank you so much for your help. I am disappointed that this can't be resolved. I hope they come out with an update to the app that will help fix the bugs.

Share this post


Link to post
Share on other sites

No problem, you might want to send Justin a private message.

Have you ever seen anything of the game, like the Sega or DF logos?

It's hard to alter the gfx settings if you can't locate/alter the appropriate config file. Maybe you want to try to start the game directly from the Steam folder without the Steam client ~/Library /Application Support/Steam/Steam Apps/Common/The Cave/ I mean we are talking about the Steam version, right?

If you open the The Cave package there (Resources/Data/Config/) are also a number of config files located but i can't remember that f.e. Default.cfg contained similar variables. There exist a number of gfx settings though but i never played around with them.

Maybe you want to delete the game and try a fresh install.

Maybe some save settings can be shared from a working installation.

If you have windows installed as well (bootcamp or virtual machine with hw acceleration) you might want to try it there, or another computer.

(If you take the time you could analyse what's going on in the background and maybe reverse engineer but that's a whole different story then.)

Share this post


Link to post
Share on other sites
Found the Library/ApplicationSupport section, but there wasn't a DoubleFine folder. I opened all the folders in the Application Support folder and there wasn't anything there that was DoubleFine or The Cave related. The Cave is still installed on my computer.

Do you know if there is another area that the folder might be in?

Thank you.

Had the same Issue and found a folder ~/Library/Containers/com.doublefine.thecave/

Containing some sort of mirror of the HD with the config files in it VERY strange

Share this post


Link to post
Share on other sites
Found the Library/ApplicationSupport section, but there wasn't a DoubleFine folder. I opened all the folders in the Application Support folder and there wasn't anything there that was DoubleFine or The Cave related. The Cave is still installed on my computer.

Do you know if there is another area that the folder might be in?

Thank you.

Had the same Issue and found a folder ~/Library/Containers/com.doublefine.thecave/

Containing some sort of mirror of the HD with the config files in it VERY strange

For the Mac App store version that is currently where the files are stored. I'll be updating the FAQ with their location, sorry about the confusion.

Also Taumel check your pms please!

Share this post


Link to post
Share on other sites

So, any news?

I'd really like to be able to play the game at some point.

I'm still getting extremely poor performance on my PC, even when running The Cave in low res with everything turned off, only about 12 fps or so. I'd assume my machine should be able to run a game like this in the highest resolution with all the bells and whistles, so I'm guessing it's a bug or incompability issue.

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130104-1431)

BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10

Processor: Intel® Core i7-2600K CPU @ 3.40GHz (8 CPUs), ~3.4GHz

Memory: 8192MB RAM

Available OS Memory: 8168MB RAM

Page File: 2646MB used, 13689MB available

DirectX Version: DirectX 11

---------------

Display Devices

---------------

Card name: NVIDIA GeForce GTX 570

Manufacturer: NVIDIA

Chip type: GeForce GTX 570

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV;_1081&SUBSYS;_25511462&REV;_A1

Display Memory: 4049 MB

Dedicated Memory: 1233 MB

Shared Memory: 2815 MB

Current Mode: 1920 x 1080 (32 bit) (60Hz)

Monitor Name: SyncMaster P2770H/P2770FH (Digital)

Monitor Model: SyncMaster

Monitor Id: SAM0612

Native Mode: 1920 x 1080(p) (60.000Hz)

Output Type: DVI

Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Driver File Version: 9.18.0013.1407 (English)

Driver Version: 9.18.13.1407

DDI Version: 11

Driver Model: WDDM 1.1

Driver Attributes: Final Retail

Driver Date/Size: 2/10/2013 04:25:27, 17987192 bytes

WHQL Logo'd: Yes

WHQL Date Stamp:

Device Identifier: {D7B71E3E-53C1-11CF-AD72-5C051CC2C435}

Vendor ID: 0x10DE

Device ID: 0x1081

SubSys ID: 0x25511462

Revision ID: 0x00A1

Driver Strong Name: oem59.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section077:9.18.13.1407:pci\ven_10de&dev;_1081

Rank Of Driver: 00E02001

Share this post


Link to post
Share on other sites

No idea about the windows version but did you try out the usual steps already?

Like having the latest version of the game, latest updates for your system, latest Direct X9 drivers, latest gfx drivers (sometimes you need to remove the old ones first), latest device drivers, adjusting (playing around) with the game settings (f.e. choosing the lowest possible resolution isn't always the best thing to do, sometimes a more common resolution can cause less issues), are you sure your system is running properly (any viruses, anti-virus-software or other services doing weird stuff in the background, ...), disabling gaming devices temporarily (disconnecting the controller/second monitor, disabling the sound card), playing around with bios settings (altering cpu cores, changing to more moderate settings), checking if some gfx driver settings overrule the game settings, does your gpu operate properly (manufacturing defect, is the fan alright, is your power supply strong enough), do there exist other games which cause the same issues or do similar games run just fine, browsing the internet for comparable problems, contacting Justin, ...

There is quite a lot you can play around with, especially on a PC, which is good and bad at the same time.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...