Sign in to follow this  
leinardi

[BUG][Linux] I can not get full screen working properly on native resolution

Recommended Posts

As stated in the subject I can not see the game in full screen:

Screenshot 1

Screenshot 2

Oddly, the full screen seems work properly with resolutions lower than the native (1920x1080@60Hz).

I get the exact same defect with Stacking.

No problem with The Cave (works properly with native resolution).

My system specs:


Processor Information: 

   Vendor:  GenuineIntel 

   Speed: 2301 Mhz 

   8 logical processors 

   4 physical processors 

   HyperThreading:  Supported 

   FCMOV:  Supported 

   SSE2:  Supported 

   SSE3:  Supported 

   SSSE3:  Supported 

   SSE4a:  Unsupported 

   SSE41:  Supported 

   SSE42:  Supported 



Network Information: 

   Network Speed:  



Operating System Version: 

   Ubuntu 13.04 (32 bit)

   Kernel Name:  Linux 

   Kernel Version:  3.8.8-030808-generic

   X Server Vendor:  The X.Org Foundation 

   X Server Release:  11303000 

   X Window Manager:  Compiz 

   Steam Runtime Version:  steam-runtime-release-i386_2013-04-16



Video Card: 

   Driver:  NVIDIA Corporation GeForce GTX 670M/PCIe/SSE2 



   Driver Version:  4.3.0 NVIDIA 319.17

   Desktop Color Depth: 24 bits per pixel 

   Monitor Refresh Rate: 60 Hz 

   VendorID:  0x10de 

   DeviceID:  0x1213 

   Number of Monitors:  2 

   Number of Logical Video Cards:  1 

   Primary Display Resolution:  1920 x 1080 

   Desktop Resolution: 3840 x 1080 

   Primary Display Size: 6,30" x 3,54"  (7,20" diag) 

                                           16,0cm x 9,0cm  (18,3cm diag) 

   Primary Bus: PCI Express 16x 

   Primary VRAM: 3072 MB 

   Supported MSAA Modes:  2x 4x 8x 16x 



Sound card: 

   Audio device: VIA VT1802 



Memory: 

   RAM:  16167 Mb 



Miscellaneous: 

   UI Language:  Italiano 

   LANG:  it_IT.UTF-8 

   Microphone:  Not set 

   Total Hard Disk Space Available:  501673 Mb 

   Largest Free Hard Disk Block:  4830 Mb 



Installed software: 



Recent Failure Reports:    

Share this post


Link to post
Share on other sites

Did you get this version through Steam or using the direct download from HiB? The Steam version should have this fixed, but I'm not sure if HiB has updated their builds with this fix yet.

Share this post


Link to post
Share on other sites

Hi, thanks for the quick response.

Both games have been downloaded through Steam.

Share this post


Link to post
Share on other sites

Hi there,

I may be suffering from the same bug. The difference is that I do not get to see any screen at all. I have installed the necessary 32-bit libraries. (I have 64-bit system). I installed "CostumeQuest-Linux-2013-05-07-setup.bin", which would be the latest version as of now. This is what happens for me:

1. Run Cq.bin.x86 from the commandline.

2. The screen changes resolution and becomes black a few times.

3. The normal desktop returns.

The program hasn't crashed however. The terminal window shows that the program is still running and I can hear the music playing. I've attached a screen shot of the final state. This is from

Some system information:

cpu:

AMD Athlon X2 Dual-Core QL-60, 1900 MHz

memory:

2 Gb

graphics card:

nVidia GeForce 9100M G

256 Mb

NVIDIA Driver Version:

313.30

Operating system:

Kubuntu 13.04 raring 64-bit

Linux birdy 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

costumequest.jpg

costumequest.jpg.cb6139ac284a405506cf093

Share this post


Link to post
Share on other sites

I can't get It to run at all when try to open Cq.bin.x86 in the terminal I get this.

X Error of failed request: BadWindow (invalid Window parameter)

Major opcode of failed request: 137 (NV-GLX)

Minor opcode of failed request: 4 ()

Resource id in failed request: 0x8400002

Serial number of failed request: 92

Current serial number in output stream: 92

I guess I will just play this in Windows would have been nice to play this in Linux too bad.

Share this post


Link to post
Share on other sites

The full screen seems oddly work with resolutions lower than the native (1920x1080@60Hz).

[/code]

Hey there leinardi,

I have the same issue on my system. A quick workaround is to set the resolution you want to play in before you actually start the game. You can do that manually through Ubuntu's display settings. Or you can change the resolution by setting a 'Lauch Option' directly in steam:

xrandr -s 800x600 && %command% && xrandr -s 1920x1080

You may have to install the 'mesa-utils' package if xrandr is not already installed. I hope this will help while double fine works on a more permanent fix.

Cheers.

Share this post


Link to post
Share on other sites

Thanks for the suggestion, but unfortunately this workaround just mess up my resolution.

Also my goal is to run the game at native resolution, not at a lower resolution such as 800x600.

Share this post


Link to post
Share on other sites

Sorry I misunderstood you. I thought you meant the game worked oddly at a lower resolution, while you mean that oddly, the game works at lower resolutions!

Maybe you could try removing the screen.dat file? On my system, it's located here:

~/.local/share/doublefine/stacking/screen.dat

Also, I'm think your dual-screen setup might confuse steam for some reason? Maybe you could try 'xrandr -s 1920x1080 && %command%' to see if it helps. That's just a wild guess.

Share this post


Link to post
Share on other sites
Sorry I misunderstood you. I thought you meant the game worked oddly at a lower resolution, while you mean that oddly, the game works at lower resolutions!

Exactly, however it is not your fault, but of my bad English :-)

Also, I'm think your dual-screen setup might confuse steam for some reason?

I doubt it is due to Steam: all Valve games are working properly. Also other DF titles like Psychonauts, The Cave and Brutal Legend work properly without the need of any workaround.

Maybe you could try 'xrandr -s 1920x1080 && %command%' to see if it helps.

Already tried, but without success.

However I found a workaround for Stacking: http://www.doublefine.com/forums/viewthread/9176/#273766

Share this post


Link to post
Share on other sites

Hi everyone,

I'm facing this very problem that the OP posted and non of the suggestions have worked :(

Is there any fix for this ?

Thanks all

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this