Sign in to follow this  
JustLie

Costume Quest Crashing [MAC]

Recommended Posts

I've downloaded Costume Quest through the humble bundle, DRM-free. I get to the start screen, but as soon as I press an empty save game slot the loading screen comes up for a second and then the whole thing crashes. Doesn't matter if I turn all the advanced settings off. Tried getting the game through Steam as well to see if that would help, but I get exactly the same problem. I'm on a Macbook Pro with Lion.

Share this post


Link to post
Share on other sites

Yeah, I have the same problem. I've uploaded one of the crash logs here, if that's any help.

Share this post


Link to post
Share on other sites

Same problem + Stacking is glitchy and Psychonauts crashed after getting the first achievement.

Share this post


Link to post
Share on other sites

i don't know whether its comforting or disheartening to see that of all the derps and hiccups my mac is guilty of, this one isn't my fault...

my crash log looks about the same as wintervail's- same os version, same report crash number.

the game also quits when attempting to choose a slot for Grubbins on ice.

Share this post


Link to post
Share on other sites

We may have a fix for this set of crashes. Our QA is testing it in a private Steam beta now and we'll likely make that public by noon pacific. For those using the Humble direct download, we'll be updating those binaries later today or on Monday (the patch process there is a bit more involved).

Share this post


Link to post
Share on other sites

Had this game for 5 days and still can't play it, is there going to be an update soon?

Share this post


Link to post
Share on other sites
Had this game for 5 days and still can't play it, is there going to be an update soon?

Are you playing the Steam version or the HiB direct download? The Steam version is newer and has several crash fixes, so try it there if you can. If you're still getting crashes, can you post the results of the Crash Report here so that I can tell what's going on? Thanks!

Share this post


Link to post
Share on other sites
Don't know about WillC, but I'm still getting crashes using the Steam version. Here's another crash report.

Ok. That one is, AFAIK, specific to HD 3000 (and maybe HD 4000) on Lion (i.e. 10.7.5). If you can upgrade to Mountain Lion, this will be fixed. I'm also going to look into the issue here, but it'll take me a bit since I'll have to do the downgrade dance, which is never very fun.

Share this post


Link to post
Share on other sites

Ah, I see. Unfortunately upgrading isn't really an option right now, but I'll look into it. Thanks for all your work on this, and for the great games!

Share this post


Link to post
Share on other sites

I'm on 10.8, and after the Steam patch, it is still crashing after I choose the save slot. Log here.

Share this post


Link to post
Share on other sites

Ok it's working now after I updated my computer. Thans very much for your help.

Share this post


Link to post
Share on other sites

So, it's been the better part of a week. For those of us with 10.7.5 and the HD 3000 graphics card, is there any news? Are we likely to see a fix, or is this a case of "Get a real OS, N00B"?

Share this post


Link to post
Share on other sites

We had to order a Mac with that specific video card, but we have it now and are working on fixing. We will let you know when we have a fix and an update.

Share this post


Link to post
Share on other sites
Ok it's working now after I updated my computer. Thans very much for your help.

Did you update your OSx?

Share this post


Link to post
Share on other sites

Posting this for my fiancee. She recently picked up the humble bundle and is running a macbook pro with the latest OS updates.

She's running into an issue with weird blue artifacting in both costume quest and stacking, but not for brutal legend. Any ideas on this? I'm not a huge Mac guy, so I'm at a loss. Can someone point me in the right direction? Is there any information you need from me?

Share this post


Link to post
Share on other sites
Posting this for my fiancee. She recently picked up the humble bundle and is running a macbook pro with the latest OS updates.

She's running into an issue with weird blue artifacting in both costume quest and stacking, but not for brutal legend. Any ideas on this? I'm not a huge Mac guy, so I'm at a loss. Can someone point me in the right direction? Is there any information you need from me?

What video card is she using? Probably an Intel HD 3000 or 4000? Also, is she running Lion (10.7.x) or Mountain Lion (10.8.x)?

Share this post


Link to post
Share on other sites
Posting this for my fiancee. She recently picked up the humble bundle and is running a macbook pro with the latest OS updates.

She's running into an issue with weird blue artifacting in both costume quest and stacking, but not for brutal legend. Any ideas on this? I'm not a huge Mac guy, so I'm at a loss. Can someone point me in the right direction? Is there any information you need from me?

What video card is she using? Probably an Intel HD 3000 or 4000? Also, is she running Lion (10.7.x) or Mountain Lion (10.8.x)?

An HD 3000 and 10.7.5

Share this post


Link to post
Share on other sites
Posting this for my fiancee. She recently picked up the humble bundle and is running a macbook pro with the latest OS updates.

She's running into an issue with weird blue artifacting in both costume quest and stacking, but not for brutal legend. Any ideas on this? I'm not a huge Mac guy, so I'm at a loss. Can someone point me in the right direction? Is there any information you need from me?

What video card is she using? Probably an Intel HD 3000 or 4000? Also, is she running Lion (10.7.x) or Mountain Lion (10.8.x)?

An HD 3000 and 10.7.5

Ok. Good times. I'm working on a crash bug in Stacking on the same hardware but different OS. I'll switch to CQ and down-grade the OS after that.

Share this post


Link to post
Share on other sites

Ok. Good times. I'm working on a crash bug in Stacking on the same hardware but different OS. I'll switch to CQ and down-grade the OS after that.

Wow. You guys are awesome. Please keep me posted.

Would it be easier for her to upgrade her OS? She's been debating doing it for awhile.

Share this post


Link to post
Share on other sites

Ok. Good times. I'm working on a crash bug in Stacking on the same hardware but different OS. I'll switch to CQ and down-grade the OS after that.

Wow. You guys are awesome. Please keep me posted.

Would it be easier for her to upgrade her OS? She's been debating doing it for awhile.

I just fixed the Stacking bug and am about to look at this CQ bug, at least as soon as we have a good way for me to boot back to 10.7 from 10.8. If your SO can update to 10.8.3, I'd say do it. It'll fix this bug and you'll have all the benefits of a fresh OS update.

Share this post


Link to post
Share on other sites

Hi,

I have the same specs as the guy above me (Lion, 3000 HD). CQ crashes after I choose a save slot and Stacking and Brutal legend have the aforementioned blue bits. Upgrading is not really an option right now. Would be happy for any and all help.

Thanks for being awesome, Double Fine!

Share this post


Link to post
Share on other sites

Hi,

have the direct download binaries been updated? I'm kinda not using steam, and am experiencing these problems as well (CQ crashes after choosing a safe slot, though I do get to see the game for about half a second, Stacking is glitchy, but my machine is probably too slow for that anyway, didn't try the others). Different to everyone else here I'm still using Snow Leopard (10.6.8) and have an Intel HD 3000... Would rather not upgrade the OS right now if I don't have to.

Crash report: https://dl.dropboxusercontent.com/u/29802570/cq_crash.txt

Share this post


Link to post
Share on other sites
Hi,

I have the same specs as the guy above me (Lion, 3000 HD). CQ crashes after I choose a save slot and Stacking and Brutal legend have the aforementioned blue bits. Upgrading is not really an option right now. Would be happy for any and all help.

Hello? Anyone here? My games still aren't working. It's been a few weeks now. Help?

Share this post


Link to post
Share on other sites

I really respect Double Fine as a game developer because they truly make some wonderful games, but this is getting kind of ridiculous. Could we at least get an update of some sort, or a flat-out "no" as to whether or not Lion users are getting a fix?

Share this post


Link to post
Share on other sites

Hi all, sorry for the delay. We have posted the fixed builds to steam and HiB so you should be good to go now! Make sure you update to the latest and give it a try!

Let us know if you run into any other problems.

Share this post


Link to post
Share on other sites
Hi all, sorry for the delay. We have posted the fixed builds to steam and HiB so you should be good to go now! Make sure you update to the latest and give it a try!

Let us know if you run into any other problems.

So how exactly do I go about getting a fixed build for HiB?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this