• Announcements

    • Spaff

      These Forums are closing!   10/04/2019

      After more than a decade of serving this community well, these forums have finally run their course and it's time to close them down. That doesn't mean we want to close the doors on our community, quite the opposite!
      Our discord server grows ever busier by the day, and we encourage all Double Fine fans to meet us over there www.discord.gg/doublefine In a short time these forums will become a read only archive and will remain that way until they become needed again.
      You never know, it might happen.  There is... a prophecy. Thank you all for being part of these forums, and remember that the fun is definitely not over - so please join us on Discord! Love ya, Spaff, Tim, Info Cow, and all of Double Fine.
Sign in to follow this  
amateursuperhero

Costume Quest Lagging

Recommended Posts

Hello Doubly Fine people,

This is my first post, on any forum... ever. Please keep that in mind. Anyway, I have searched the internet forums and the DF forums for about 4 days and cannot come up with a way to make this game run without lagging. I bought it on STEAM and made sure I had the requirements to play the game, but it I can't seem to get it to work well, and as anyone who has played this game knows, can't really do battle effectively with lagging in the game.

Any HELP will be appreciated. What I mean by "HELP" is anything that might point me in the direction of resolving my lagging issue, it doesn't help me to know that the game runs great on your computer.

I also have to say that I am new to computer and/or Steam gaming so I ask you to be patient with me, though I pick up on things fairly quick.

Some info on my laptop:

HP Pavilion dv2700 Notebook PC

Windows Vista (32-bit) (SP1)

Intel Core 2 Duo CPU T5550 @ 1.83GHz

3GB Ram

Mobile Intel 965 Express Chipset Family (Graphics)

This is about all I know about my laptop. If I missed something just let me know.

Thank you for your time.

Share this post


Link to post
Share on other sites

At a glance, I see that you Graphics device "Mobile Intel 965 Express Chipset Family (Graphics)" is below our minimum specifications.

You can try updating the drivers for your graphics device, but we can't guarantee its efficacy in fixing your lag issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this